Fiber Cuts affecting Customers along with some Content Providers in Mumbai Metro
Major incident
Mumbai
Mumbai Peering
Mumbai Network
2026-09-04 11:42 IST
· 33 minutes
Updates
Resolved
September 4, 2026 · 12:15 IST
One of our primary core links has been restored, and network traffic is currently recovering.
Issue
September 4, 2026 · 11:42 IST
Please be advised that Extreme IX Mumbai is currently experiencing a network disruption caused by multiple fiber cuts affecting both our primary and backup links.
This issue impacts connectivity for all members and content providers. Our technical teams are actively working on repairs to restore full service as quickly as possible. We sincerely apologize for the inconvenience and will provide further updates as they become available.
← Back
Extreme Port Status