Fiber Cuts affecting Customers connected in multiple DCs along with some Content Providers

Major incident Chennai Chennai Peering Chennai Network
2026-06-19 04:52 IST · 36 minutes

Updates

Resolved

The issue has been resolved, and all services are now functioning normally.

June 19, 2026 · 05:44 IST
Issue

We are currently experiencing connectivity issues impacting multiple Chennai data center locations due to simultaneous failure of both primary and backup fiber links.

Affected Data Centers

CtrlS Chennai DC2
Digital Connexion MAA10
STT Chennai DC2

Affected Services / Content Providers

Zscaler Peering 1 & 2
Cisco Umbrella
Netskope Peering

Current Impact
Connectivity to the above content providers is unavailable from the affected data centers. Traffic paths dependent on these peerings may experience service disruption, degraded performance, or loss of connectivity.

Root Cause
Initial investigation indicates concurrent outages affecting both primary and secondary fiber circuits serving the impacted facilities.

Current Actions

Network and carrier teams are actively engaged.
Providers are investigating the fiber outages and working toward service restoration.
We are monitoring recovery progress and evaluating alternate routing options where feasible.

Update will be provided as soon as additional information or an estimated restoration timeline becomes available.

June 19, 2026 · 04:55 IST

← Back