Connectivity Issue Due to Network Device Affecting NTT NAV01 Mahape and Nxtra Data Mumbai DC3

Major incident Mumbai Mumbai Peering Mumbai Network
2026-06-17 19:40 IST · 50 minutes

Updates

Resolved

The network issue affecting connectivity to the NTT NAV01 Mahape and Nxtra Data Mumbai DC3 data centers has been resolved, and all services are operating normally.

Our engineering team identified the issue as a hardware-related fault within the network infrastructure and has implemented corrective measures to restore service and prevent recurrence.

We apologize for the disruption and appreciate your patience and understanding while we worked to resolve this matter.

June 17, 2026 · 20:48 IST
Issue

We are currently investigating an ongoing issue affecting one of our network devices, which has resulted in the isolation of the NTT NAV01 Mahape and Nxtra Data Mumbai DC3  data centers.

Our engineering team is actively working to identify the root cause and restore full connectivity as quickly as possible. Further updates will be provided as soon as more information becomes available.

We apologize for the inconvenience and appreciate your patience.

June 17, 2026 · 19:42 IST

← Back