Traffic degradation of Google Peering 1, 2 & 3 + GooglePNI 1 & 2 (AS15169)

Minor incident Delhi Delhi Peering
2026-06-05 11:00 IST · 13 hours, 54 minutes

Updates

Investigating

We have received an update from Google regarding an ongoing facility outage affecting their Delhi (DEL) metro region. The incident is related to a fire at a facility, resulting in the isolation of several network clusters and a reduction in local peering capacity.

To maintain service stability, Google has implemented traffic engineering measures to reroute ingress and egress traffic through adjacent metro locations.

Potential Impact

Increased latency for traffic to and from the Delhi region.
Traffic may be rerouted via alternate regional hubs, including Singapore.
Temporary withdrawal of certain local prefixes to manage available capacity.
Possible routing instability for networks relying on Delhi-based interconnections.

Google’s engineering teams are currently on-site and actively working to restore normal operations. Customers may observe changes in routing paths and performance until restoration efforts are completed.

We are continuing to monitor the situation closely and will provide further updates as additional information becomes available.

June 5, 2026 · 23:39 IST
Monitoring

We are happy to report that we are observing recovery across all previously degraded Google traffic paths, and traffic levels are gradually returning to normal.

At this time, we still have not received any official information or communication from the Google team regarding the cause of the degradation. Nevertheless, the current indicators suggest that the situation is improving.

We will continue to monitor the traffic closely and provide further updates should any new information become available.

Thank you for your patience and understanding.

June 5, 2026 · 18:52 IST
Issue

We are currently observing traffic degradation towards Google services. Based on preliminary information received, this may be related to a fire incident reported at the GK-1 facility earlier today. The exact cause and impact are still under investigation.

At this time, no ETR is available. Our team is actively monitoring the situation and working with the relevant parties for further updates. Additional information will be shared as it becomes available.

June 5, 2026 · 11:10 IST

← Back