Multiple Fiber Cuts affecting Customers connected in Airtel Senthome DC along with some Content Providers

Major incident Chennai Chennai Peering Chennai Network
2026-03-31 11:10 IST · 3 hours, 22 minutes

Updates

Resolved

We received confirmation from vendor that the issue has now been fully resolved, and all services are operating normally.

March 31, 2026 · 14:31 IST
Investigating

The team is actively working on the issue. Current ETR is approximately 60 minutes from now.

Work is in progress on laying overhead fiber to restore connectivity.

March 31, 2026 · 13:38 IST
Investigating

Vendor has identified the fiber cut and is currently working to restore both the primary and secondary paths. The estimated time to resolution (ETR) is 2 hours.

March 31, 2026 · 11:39 IST
Issue

We are currently experiencing a service disruption impacting our Chennai region due to a network isolation event at the Airtel Senthome Data Center.

Both primary and secondary network paths to this data center are currently down, resulting in loss of connectivity to services hosted in this location.

Our engineering and network teams are actively working with the provider to restore connectivity as quickly as possible. We will continue to share updates as more information becomes available.

Impact: Customers with services hosted in the Chennai (Airtel Senthome DC) region may experience downtime or connectivity issues.

Next Update: We will provide an update within the next 60min or sooner if progress is made.

We sincerely apologize for the inconvenience and appreciate your patience as we work to resolve this issue.

The following content providers have been affected by this situation:

Microsoft Peering (AS8075)

Google Peering (AS15169)

Akamai Prolexic (AS32787)

March 31, 2026 · 11:10 IST

← Back