Fiber Cuts affecting Customers connected in RDC POP

Major incident Delhi Delhi Network
2025-08-18 16:33 IST · 44 minutes

Updates

Resolved

The issue has been resolved, and the link is now stable. Our team will continue to monitor it closely to ensure ongoing reliability.

Thank you for your patience and understanding. Should you have any further concerns, please feel free to contact our support team at support@x3me.net

August 18, 2025 · 18:01 IST
Issue

We have noted a significant decrease in network activity within the Extreme IX infrastructure, primarily attributed to the occurrence of multiple fiber cuts in both our primary and backup links connecting RDC POP.

We sincerely apologies for any inconvenience caused by this disruption, and our technical teams are actively working to resolve the fiber cuts and restore normal operations as swiftly as possible.

August 18, 2025 · 17:05 IST

← Back