Multiple Clients & Content Providers are affected due to Fiber Cuts

Major incident Mumbai Mumbai Peering Mumbai Network
2025-07-25 14:20 IST · 30 minutes

Updates

Resolved

The issue has been resolved.

July 25, 2025 · 15:15 IST
Monitoring

The earlier issue impacting multiple clients and content providers has been resolved. Services are now stable, and we are continuing to monitor the situation closely to ensure there are no further disruptions.

We appreciate your patience and will provide updates if needed.

July 25, 2025 · 15:07 IST
Issue

We are currently observing impact across multiple clients and content providers due to several fiber cuts affecting connectivity.

Our teams are actively working with vendors to assess the scope and restore full service as quickly as possible. We will continue to provide updates as we receive more information.

Thank you for your patience.

July 25, 2025 · 14:50 IST

← Back