Power Outage affecting Customers connected at Kalyan POP

Major incident Mumbai Mumbai Peering Mumbai Network
2025-04-25 17:44 IST · 25 minutes

Updates

Issue

The power outage at our Kalyan POP has been resolved. All impacted services have been restored and are now functioning normally.

Our teams will continue to monitor the site closely to ensure stability. We sincerely apologize for the inconvenience caused and appreciate your patience during this time.

If you continue to face any issues, please reach out to our support team.

April 25, 2025 · 18:20 IST
Issue

We are currently experiencing a power outage at our Kalyan POP, which is impacting some of our services. Our infrastructure and field teams are actively working to restore power and bring services back online as quickly as possible.

We apologize for the inconvenience caused and will continue to keep you updated with further developments.

Thank you for your patience and understanding.

April 25, 2025 · 17:44 IST

← Back