Amazon Traffic Degradation (AS16509)

Minor incident Mumbai Mumbai Peering
2025-02-11 13:41 IST · 3 weeks, 2 days, 4 hours, 46 minutes

Updates

Resolved

Traffic has been restored

March 6, 2025 · 18:28 IST
Update

The Amazon EIX port is now up, and the physical connectivity issue has been resolved.

If you are still experiencing performance issues related to Amazon, we kindly ask that you reach out to Amazon’s team directly at peering-to@amazon.com. Amazon has specifically requested that peers contact them directly for these cases to ensure efficient communication and resolution.

February 13, 2025 · 12:03 IST
Update

We notice that now the EIX port for Amazon peering (103.77.108.137) is currently down. As a result, you have observed that your bilateral session with Amazon has gone down.
We have already raised a complaint with Amazon regarding this issue and will provide you with updates as soon as we receive further information from their team.

February 12, 2025 · 11:18 IST
Issue

We are currently observing traffic degradation related to Amazon Peering (103.77.108.137).

Please note:
This matter does not involve issues within Extreme’s network but may affect overall traffic performance with Amazon due to events or activities at their end.

Action Required:
If you are experiencing performance issues related to Amazon, we kindly request you to contact Amazon’s team directly at peering-to@amazon.com. Amazon has specifically requested that peers reach out to them directly for such cases to streamline communication and resolution.

We remain committed to supporting our clients as much as possible. For further assistance, please feel free to contact us.

February 11, 2025 · 13:41 IST

← Back